[Apt-Rpm] F10. problem when installing updates, and machine locks up, or having a power out.

Nigel Henry cave.dnb2m97pp at aliceadsl.fr
Mon Apr 6 13:42:21 PDT 2009

Yesterday, I had a real problem when installing updates on F10. My machine 
which has an Asus M2N-X Plus mobo randomly freezes up. No mouse, keyboard, 
and the desktop is static like a screenshot. The only option is to press the 
reboot button on the machine.

Having rebooted, I run apt-get dist-upgrade, but there are now showing 
dependency problems due to the install of packages being interrupted.
It appears that I now have multiple instances of packages installed. I have 
the original package, and also the update to this package, so I have 2 
different versions for the same package, either installed, or partially 
installed. This goes the same for several packages.

On my Debian installs, I can fix this by running. dpkg-reconfigure -a, and 
dpkg miraculously fixes the problem. then I can just run apt-get dist-upgrade 
again, and the installation of packages will run to completion.

On Fedora 10, I had to resort to using rpm -e on all the duplicated packages, 
until the list of duplicates was reduced to zero, which took about 2 hrs. 
then I ran apt-get dist-upgrade again, and thankfully it continued to install 
the remaining packages.

Is there anything similar to dpkg-reconfigure -a that I could use on Fedora, 
which would resolve a problem like this?

I've already asked on the Fedora list, but as almost everyone there is using 
Yum, I only got one reply, and that was Yum related.

I'm not giving up on using apt on Fedora. I've been using it since Fedora Core 

Thanks for any solutions to the problem.


More information about the Apt-Rpm mailing list